INC0601254 - EMEA UC conference customers unable to make credit card payments *No impact to conferencing services*
Incident Report for Intrado
Resolved
The replacement drive was installed, and the services were confirmed fully operational. This incident has been resolved.
Posted Aug 04, 2020 - 20:08 CDT
Update
The replacement drive is on-site, and Intrado teams are arranging resources to complete the swap.
Posted Aug 04, 2020 - 12:19 CDT
Identified
Intrado UC conferencing customers within Europe who have opted for credit card payments against their invoices are currently unable to complete those payments. Teams have identified the affected device and are awaiting a replacement at this time. The current expectation is that this will be mitigated within 24 - 48 hours.

Please note, this issue does not affect any production services offered by Intrado - this is limited strictly to EMEA UC customers' ability to complete credit card payments to Intrado.
Posted Aug 02, 2020 - 15:58 CDT